归档之于 ‘ 2016 年十二月

centos7下全程yum安装适用于dbshop的LNMP环境(转)

作者:蓝染君 (QQ:372463778)

服务器:阿里云ECS 1核1G 1M
操作系统:centos7.2
软件搭配:nginx1.10.2 + mariadb5.5.52 +php5.4.16

下面我们开始安装:

1、更新系统

2、安装nginx

启动nginx

开机启动nginx

2、安装[……]

Read more

php中opcache的使用详解(转帖)

简述

关于opcode缓存的概念可以参考鸟哥的文章:http://www.laruence.com/2008/06/18/221.html
目前为php提供opcode缓存的扩展有很多,比如:Zend Opcache,xcache,eAccelerator,apc等等。

为什么选择opcache呢?

  • 官方出品,这就保证了会持久更新,而其他一些扩展如apc已经很久都没有更新过了;
  • 适配php5.2、5.3、5.4,而且在php5.5版本之后自带了opcache,不需要额外安装,在非 Windows 平台使用
    zend_extension=/full/path/to[……]

Read more

Apache 下的安全模块mod_security

mod_security是一个集入侵检测和防御引擎功能的开源web应用安全程序(或web应用程序防火墙).它以Apache Web服务器的模块方式运行, 目标是增强web应用程序的安全性, 防止web应用程序受到已知或未知的攻击.

mod_security 也提供 Nginx 扩展模块。

本人安装完后,并启用,发现有些正常的url都被拦截了,也是懒得去设置规则什么的,直接给关闭了,毕竟阿里云本身也带着这些拦截功能。

下面说一下Ubuntu下的Apache内的安装

先查找一下

发现有 libapache[……]

Read more

apt的简单用法记录

apt-cache search # ——(package 搜索包)
apt-cache show #——(package 获取包的相关信息,如说明、大小、版本等)
sudo apt-get install # ——(package 安装包)
sudo apt-get install # —–(package – – reinstall 重新安装包)
sudo apt-get -f install # —–(强制安装?#”-f = –fix-missing”当是修复安装吧…)
sudo apt-get remove #—–(packag[……]

Read more

return top